ERROR

ArcGIS Data Store has detected an issue with 'db'

Last Published: April 19, 2024

Error Message

Attempts to publish a hosted feature layer in ArcGIS Pro to ArcGIS Server or open a hosted feature layer in Portal for ArcGIS fail and the following warning or error messages are returned in the ArcGIS Server logs or datastore logs.

Error:
ArcGIS Data Store has detected an issue with 'db'
Error:
ArcGIS Data Store encountered too many problems. Failover may be invoked if standby is configured.
Error:
Data store machine '<machine-name>' has failed

The following errors in postgres logs (arcgisdatastore\logs\<server-name>\database\<postgresql logs>) may also be returned:

Error:
sorry, too many clients already
Error:
remaining connection slots are reserved for non-replication superuser connections
Error:
terminating connection due to administrator command
Error:
the database system is shutting down

Cause

ArcGIS Data Store is down due to following:

  • The Portal for ArcGIS, ArcGIS Server and/or ArcGIS Data Store services are not running.
  • The machine running ArcGIS Data Store does not have sufficient resources such as CPU, RAM and/or storage.
  • The data store is not validated in ArcGIS Server Manager.
  • The domain account running ArcGIS Server, does not have permissions for the Data Store, arcgisdatastore, and Python27 directories. The same domain account must also be used when configuring ArcGIS Server, Portal for ArcGIS And ArcGIS Data Store.

Solution or Workaround

Restart the ArcGIS Data Store and ArcGIS Server services

On the machine, restart the ArcGIS Data Store, Portal for ArcGIS and ArcGIS Server services.

  1. On the server machine, right-click the taskbar at the bottom of the window and click Task Manager.
  2. In the Task Manager dialog box, click the Services tab.
  3. Right-click and restart the following services from the service list:
  • ArcGIS Data Store
  • Portal for ArcGIS
  • ArcGIS Server
Note:
Restart the machine running ArcGIS Data Store if the warnings and errors persist.

Upgrade the ArcGIS Data Store machine CPU, RAM and storage where necessary

The CPU, RAM or disk usage being close to 100% in Task Manager is an indication that the resources are insufficient and may require upgrades. Refer to ArcGIS Enterprise: ArcGIS Data Store 11.2 system requirements for more information.

Validate ArcGIS Data Store in ArcGIS Server Manager

If ArcGIS Data Store is not validated, refer to How To: Validate ArcGIS Data Store for further instructions.

Grant the Data Store, arcgisdatastore, and Python27 directories permission to the ArcGIS Server account

Note:
Completing this workaround may require assistance from the organization's IT department.

The default locations are in the following directories:

  • The Data Store folder
C:\Program Files\ArcGIS
  • The arcgisdatastore folder
C:\
  • The Python27 folder
C:\Python27

Complete the steps below to provide permission to the folders.

  1. Navigate to the Data Store, arcgisdatastore and Python27 folders.
  2. Right-click the folder and click Properties.
  3. Click the Security tab.
  4. Select the ArcGIS Server account from the Group or user names list.
  5. Click Edit...The Edit icon.
  6. Check the Allow check box to permit Full control.
  7. Click OK.
  8. Restart the ArcGIS Server service. Refer to ArcGIS Server: Start and stop services for instructions.

Article ID:000026836

Software:
  • ArcGIS Data Store
  • ArcGIS Enterprise 11 2
  • ArcGIS Server
  • ArcGIS Enterprise 11 0
  • ArcGIS Enterprise 11 1
  • Portal for ArcGIS

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