ERROR

ArcGIS Data Interoperability for Pro requires an All Users installation of ArcGIS Pro <version number>

Last Published: September 15, 2022

Error Message

When attempting to install the ArcGIS Data Interoperability extension for ArcGIS Pro, the following error message is returned:

Error:   
ArcGIS Data Interoperability for Pro requires an All Users installation of ArcGIS Pro <version number>.
The error message is returned when attempting to install the ArcGIS Data Interoperability extension.

Cause

A per-user installation is made when installing ArcGIS Pro on the local machine before installing the ArcGIS Data Interoperability extension.

Solution or Workaround

Uninstall ArcGIS Pro from the local machine using Windows Control Panel or Windows Settings and reinstall ArcGIS Pro on the local machine. Ensure the Anyone who uses this computer (all users) option is checked in the ArcGIS Pro Setup window. Refer to ArcGIS Pro: Install ArcGIS Pro for more information.

Install ArcGIS Pro with the 'all users' option.

Article ID:000028378

Software:
  • ArcGIS Pro 3 0
  • ArcGIS Pro 2 8 x
  • ArcGIS Data Interoperabilityx
  • ArcGIS Pro 2 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options