Error Message
The message "Add Virtual Server failed" is received when trying to add an ImageServer-ArcMap1 virtual server.
Cause
The following may cause ArcIMS to return this error message:
1. The server check box was not marked in the right pane of the New Virtual Server dialog box.
2. The ArcIMS Monitor service has stopped.
3. ArcMap Server is unavailable (this may be due to a problem with the license configuration).
Solution or Workaround
To troubleshoot this, you will want to create an AppServer log file. To create the log file you need to:
1. Stop ArcIMS.
2. Open the appserver.properties file (<ArcIMS Installation>/AppServer/) and set debug = true and logtofiles = true.
3. Restart ArcIMS.
4. Try to add a new ImageServerArcMap virtual server.
5. Open the AppServer log file (created under <ArcIMS Installation>/AppServer/log/).
- If the message states “ERROR message = “Tag SERVER is missing”, then the server check box was not marked.
To correct this, simply create a new virtual service and make sure to check the check box next to the server in which you want the virtual server to reside. - If the message states “ERROR message = “Unable to create ServiceGroup”, it is likely that the monitor has stopped or that there is an issue with the license.
Check your services to make sure the monitor is running. If it is not, restart it and retry adding the virtual server.
If there is a License Manager error, you will need to check the license configuration.