ERROR

A valid ArcGIS License Manager for your Licensing Portal could not be found on the specified host

Last Published: September 24, 2025

Error Message

When attempting to license ArcGIS Pro using the Named User License (ArcGIS Enterprise), an the following error may be encountered after signing in.

A valid ArcGIS License Manager for your Licensing Portal could not be found on the specified host.

error message on sign-in

The ArcGIS Pro machine is unable to connect to the License Manager, which is present on a cloud machine (Azure/AWS) alongside the Enterprise deployment.

Cause

The required ports for the License Manager (27000-27009) where not added in the security group (outbound and inbound rules) applied to the cloud machines where the License Manager is hosted. 

Solution or Workaround

  1. Check the portal license file, make sure the cloud instance ID is used instead of the MAC address of the machine, use the public URL hostname of the machine as the hostname parameter, and use 2700 as the port.
  2. In the Service.txt file of License Manager, set the Vendor ArcGIS Port other than 27000 and ensure VM_UUID is present instead of ‘ANY’ after importing the portal license file.
  3. Add the inbound and outbound rules in the Windows Defender firewall where License Manager and the portal for ArcGIS are present for the 27000-27009 port range.
  4. Add the port range 27000-27009 in the Azure/AWS network security group, which is applied to the cloud machine for inbound and outbound network traffic. 

Article ID: 000037231

Software:
  • ArcGIS Pro

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