ERROR

A core license could not be found

Last Published: March 23, 2021

Error Message

When launching ArcGIS Pro and signing in using enterprise credentials, the following error message is returned:

Error:   
A core license could not be found. Select another licensing option or contact your administrator to update your licenses.

Cause

This issue has two potential causes:

  • The named user JSON authorization file is authorized in ArcGIS Enterprise, but is not authorized on ArcGIS License Manager.
  • ArcGIS Pro retains old/corrupt licensing information after an upgrade which must be cleared out.

Solution or Workaround

Perform the following steps to resolve the issue:

Issue 1: The named user JSON authorization file is authorized in ArcGIS Enterprise, but is not authorized on ArcGIS License Manager.

  1. Launch ArcGIS License Server Administrator.
  2. Select Authorization in the left pane.
  3. In the Version drop-down menu, select Named User, and click Authorize Now.
  1. Select the authorization option: I have received an authorization file and am now ready to finish the authorization process.
  2. Click Browse, and navigate to the JSON authorization file used with ArcGIS Enterprise. Click Next.
  1. A dialog box displays, indicating the named user licenses are applied. Click OK.
  1. Click OK to close ArcGIS License Server Administrator.

Issue 2: ArcGIS Pro retains old/corrupt licensing information after an upgrade which must be cleared out.

Warning:   
The instructions below include making changes to essential parts of your operating system. It is recommended that you backup your 
operating system and files, including the registry, before proceeding. Consult a qualified computer systems professional, if necessary.

Esri cannot guarantee results from incorrect modifications while following these instructions. Therefore, use caution and proceed 
at your own risk. This process resets ArcGIS Pro to its default settings. Any customizations or preferences (not project data) will be lost.
  1. Close ArcGIS Pro.
  2. Navigate to: C:\Users\<local profile>\AppData\Local\ESRI_Licensing
  3. Rename ESRI_Licensing to ESRI_Licensing_old.
  4. Open the Registry Editor and navigate to HKEY_CURRENT_USER\Software and rename the ESRI hive to ESRI_old
  5. Reopen ArcGIS Pro and attempt to consume a Named User license. 

Article ID:000022898

Software:
  • Portal for ArcGIS
  • ArcGIS Pro 2 x

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