Error Message
HTTPS web pages fail to load when accessed by an ArcGIS Server Account. In the ArcGIS Server logs, the following error message is returned:
Error:
A connection with the server could not be established (WinINet Error while using HTTPS security, 12029), URL = https://machine.domain.com:6443/arcgis/services
Cause
- Certain settings in Windows Internet Options are incorrect.
- RSA encryption is disabled on the ArcGIS Server machine.
Solution or Workaround
Depending on the cause, perform the workarounds below:
Configure the Internet Options settings via Internet Explorer
- If the ArcGIS Server machine uses Internet Explorer 10 or below, upgrade to Internet Explorer 11.
- Launch Internet Explorer as the ArcGIS Server Account. To do so, highlight Internet Explorer, and press SHIFT + Right Click > Run as different user.
- Click the Tools menu in Internet Explorer. Select Internet Options.
- In the Connections tab, select LAN settings. Disable all forward proxy settings by unchecking the boxes.
- In the Advanced tab, click Reset...
- Close Internet Explorer and re-launch it as the ArcGIS Server Account (highlight Internet Explorer, and press SHIFT + Right Click > Run as different user.
- Access an HTTPS page (for example, https://machine.domain.com:6443/arcgis). The page loads.
Enable RSA encryption
Enable RSA encryption on the ArcGIS Server machine. This process must be performed by the organization's IT. Refer to ArcGIS Server: Secure ArcGIS Server communication for more information on RSA encryption in ArcGIS Enterprise.