Error Message
When authorizing ArcGIS Desktop or ArcGIS Pro, the following error is returned:
Error:
8417: No record found.
Cause
The following are the known causes for this error:
- The authorization number is invalid
The authorization number for ArcGIS Desktop or ArcGIS Pro is incorrect or has expired. - The license version is incorrect
The license to authorize ArcGIS Desktop or ArcGIS Pro is of a different version. For example, using a version 10.0 license to authorize ArcGIS Desktop version 10.1 and above triggers the error.
Solution or Workaround
Depending on the cause, use one of the following solutions:
- The authorization number is invalid
Check the correct authorization number in My Esri or renew the license if it has already expired.
Follow the steps below to check the authorization number:
- Log in to My Esri.
- Click My Organizations > Licensing.
- Click View Authorizations.
- Click the license. The authorization code can be viewed under the Authorization Number column.
Note:
If the authorization number is correct and the error reoccurs, contact Esri Support Services for a new authorization number.
- The license version is incorrect
Ensure that the correct version of the license is used according to the version of ArcGIS Desktop or ArcGIS Pro being authorized. The license version can be checked at My Esri.
Follow the steps below to check the license version:
- Log in to My Esri.
- Click My Organizations > Licensing.
- Click View Authorizations to see the version of the license.