ERROR

Error 404 - File or directory not found when using the SAML button to access ArcGIS Online or Portal for ArcGIS

Last Published: September 17, 2025

Error Message

When clicking the SAML button to access Portal for ArcGIS or an ArcGIS Online organization, the user is redirected to an error page; the message is as follows:

Server Error
404 - File or directory not found. 
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

server error message

Cause

The SAML configuration in the Portal Organization Setting is not enabled to allow signed requests.

Solution or Workaround

Turn on the 'Enable signed request' button in Portal.

  1. Sign in to the organization with an administrator account.
  2. Go to Organization > Settings tab > Security.
  3. In the Logins section, look for SAML login and click Configure login, as shown in the next image

Configure login setting for SAML logins

  1. In the Edit SAML login dialog, click Show advanced settings.
  2. Toggle on the Enable signed request button, shown in the image below.

Edit signed request setting toggled on

  1. Save the changes.

Article ID: 000034332

Software:
  • ArcGIS Online
  • Portal for ArcGIS

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