BUG

Direct Connect does not work unless server name is included

Last Published: April 25, 2020

Description

When using Direct Connect in SDEWORKSPACE, the following errors may result during service administration and the service does not start:

"<WARNINGS><WARNING code="192" message="
[ERR0927] ImageServer on MYMACHINE: Layer with ID 0 cannot be created. Unable to establish connection with datasource."/></WARNINGS>

> Jan 7, 2005 12:58:40 PM: java.lang.String
<?xml version="1.0"?>
<ERRORS>
<ERROR message="[ERR0125] Error when trying to administer Service."/>
<ERROR message="[ERR0930] Check your map file's layers and data source connections. ArcIMS service dc cannot be created." />
</ERRORS>"

Cause

One possible cause for this set of errors is that a server name is not included in SDEWORKSPACE.

Workaround

ArcIMS is expecting a string value for the SDEWORKSPACE server attribute. Any non-space value can be assigned to this attribute. In the following example, server has been set to 'myserver'.

<SDEWORKSPACE name="sde_ws-0" server="myserver" instance="sde:sqlserver:myserver" database="mydatabase" user="map" encrypted="false" password="mypassword" />

    Article ID:000007603

    Software:
    • Legacy Products

    Receive notifications and find solutions for new or common issues

    Get summarized answers and video solutions from our new AI chatbot.

    Download the Esri Support App

    Discover more on this topic

    Get help from ArcGIS experts

    Contact technical support

    Download the Esri Support App

    Go to download options