BUG

Clear Cache Options in ArcGIS Server for the Java Platform do not affect the cache for REST API

Last Published: April 25, 2020

Description

Clear Cache Options in ArcGIS Server for the Java Platform do not affect the cache settings for REST API if updated from REST API Admin: http://<host>:8399/arcgis/rest/admin.

This bug is specific for Java Platform for ArcGIS Server. The .NET Platform updates the cache just fine.

The REST API cache information settings do not come into effect or update the rest-config.properties file if changing the mode from manual to periodic or scheduled from REST Admin.

Cause

The cause is unknown.

Workaround

As a workaround, the settings can be updated manually. Follow the steps below to update the Clear Cache settings for REST API.

  1. Update the rest-config.properties files. The cache clearance mode can be configured with the config.cache.clear-cache-mode property. The possible values are manual, scheduled, and periodic. The default is manual.

    * for periodic update -
    config.cache.clear-cache-mode=periodic
    config.cache.clear-cache-interval=60
    Note:
    The interval is specified in minutes.


    * for scheduled update -
    config.cache.clear-cache-mode=scheduled
    config.cache.clear-cache-time=23:00

    Note:
    For more details about configuring the REST cache options, refer to the Configuring the REST API Help page.

  2. Restart the ArcGIS Server Manager Service.
    [O-Image]
  3. Log in to REST Admin again and the Clear Cache Options will be updated as changed in the rest-config.properties file.

Article ID: 000010592

Software:
  • ArcGIS Server

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options