BUG

CityEngine 2012.1 authorization fails with the error: 7109:Invalid activation ID

Last Published: April 26, 2020

Description

CityEngine 2012.1 authorization fails with the following error if ArcGIS Desktop 10.0 is present on the same machine:
 

Error:   
"7109:Invalid activation ID: <authorization number>"

Cause

This error can occur when installing CityEngine 2012.1 on a system that has ArcGIS Desktop 10.0 installed.

Workaround

 
Note:
The bin folder location may vary based upon the installation path used.
  1. Go to Start > All Programs > Accessories > Command Prompt.
  • For 32-bit installations: At the command prompt type:
    cd C:\program files (x86)\esri\cityengine\bin
  • For 64-bit installations: At the command prompt type:
    cd C:\program files\esri\cityengine\bin
  1. Run softwareauthorization.exe by typing the following command:
    softwareauthorization.exe –s –lif *.prvc –ver 10.1 –verbose

    This brings up the Software Authorization Wizard and allows the user to complete authorization.

Article ID:000011612

Software:
  • ArcGIS CityEngine Prev

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