Description
Cannot print map after IP address of printer is changed.
Cause
This is a known issue with Windows.
Workaround
This issue can be resolved by clearing the printer information stored in the map document. To do this, open the map document on a computer with no printers installed, then re-save the map document.
Below are detailed steps to clear the printer information stored in the map document.
Note:
The steps below can be performed on any computer that has the same version of ArcGIS Desktop installed. Choosing a computer that has few or no printers installed can reduce the amount of effort required to perform steps 2 and 5, below.
- Navigate to Start > Settings > Control Panel > Printers and Faxes.
- Delete all printers and/or other output devices listed.
- Start ArcMap and open the map document.
- Save the map document and close ArcMap.
- If printers or other devices were deleted in Step 2, reinstall them under Control Panel > Printers and Faxes.
- Start ArcMap, open the map document and reset the Page and Print Setup options for the desired printer. The map document should now print to the proper printer.