PROBLEM

Cache tiles not found when stored in Amazon S3 Bucket

Last Published: June 1, 2020

Description

When building a cache for map and image services, it can be stored in an S3 bucket. The performance and economy of storing caches on the cloud can be advantageous when compared with storing large caches locally, and Amazon EC2 has several instance sizes and options to accommodate a variety of different needs.

After registering the Amazon S3 bucket as a cloud store and cache directory to ArcGIS Server Manager, you can start writing caches to storage in the S3 bucket.

An issue may arise, however, after publishing cached map or image services. The cache tiles were written to the S3 bucket, but the cache tiles do not load when viewing the service, . Accessing the REST endpoint of the tiles returns a 404: Not Found error, as shown in the following image.

Furthermore, after examining the caching properties of the service in ArcGIS Server Manager, it shows that the map service is drawn Dynamically from the data even though Using tiles from a cache was specified in the service editor upon publishing the service.

Cause

This happens when the arcgiscache folder name was specified in either the S3 Bucket Name or Folder fields when the Amazon S3 Bucket was registered as a cloud store and cache directory in ArcGIS Server Manager.

Solution or Workaround

Do not use the arcgiscache folder name in the fields for S3 Bucket Name or Folder when registering the S3 bucket as a cache directory in ArcGIS Server Manager. Re-register the S3 bucket as a cache directory using a different bucket and folder name.

Article ID: 000022338

Software:
  • ArcGIS Data Store
  • ArcGIS Server

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