BUG

Unable to show legend using the jspviewer sample

Last Published: April 25, 2020

Description

The legend feature works on first load of jspviewer with the SantaClara service; however, when loading a different service and clicking on the legend tool, the following javascript error occurs: "Access is denied"This problem can occur when:• ArcIMS 9.0, without Service Pack 2, is installed on Windows XP Service Pack 2 (SP2).
• ArcIMS 9.0, with Service Pack 2, is installed on Windows XP SP2 and the servlet engine is Tomcat.

Cause

The arcims_jconnect.jar file that is used by the jspviewer sample is not the most current version.

Workaround

This problem is resolved with an updated version of arcims_jconnect.jar that is installed with ArcIMS 9.0 Service Pack 2. Complete the following steps to verify the file is up-to-date.

If ArcIMS 9.0 Service Pack 2 has not been installed, install it. A link to ArcIMS 9.0 Service Pack 2, can be found in the Related Information section below.

Download ArcIMS Service Pack 2 by navigating to ESRI Online Support > Downloads > Patches & Service Packs > ArcIMS by way of the Related Information section below.

If the problem still occurs and ArcIMS Service Pack 2 has been installed on a machine that is using Tomcat as a servlet engine, perform the following:

1. Stop the Tomcat service.
2. Navigate to <Tomcat Install Directory>\webapps and delete the \jspviewer folder.
3. Start the Tomcat service.

Note:
The \jspviewer folder is re-created with the most current files.

Article ID:000007536

Software:
  • Legacy Products

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