BUG

The ArcGIS Desktop Print Dialog crashes when clicking the Setup button in an ArcGIS Engine application

Last Published: April 25, 2020

Description

Clicking the setup button on the Print Dialog crashes an ArcGIS Engine application.This issue is only reproducible in an ArcGIS Engine application that binds to a Desktop runtime and uses the Desktop Print Dialog.

Cause

The ArcGIS Desktop Print Dialog has a dependency on some Desktop only functionality. Clicking the setup button attempts to initialize the Desktop only functionality and causes the application to crash.

The fix corrects the dependency and bypasses the functionality when using the dialog in ArcGIS Engine.

Workaround

The following patch has been provided as a solution. This patch is for ArcGIS Desktop version 10.0 and is superseded by 10.0 Service Pack 1. Only install this patch if an ArcGIS Engine application is running that binds to the ArcGIS Desktop runtime and uses the ArcGIS Desktop Print Dialog.

  1. Download the Print Dialog Patch and unzip the file.
  2. Review the instructions in the QFE-DT-10-164907.doc to apply the patch.

Article ID:000011081

Software:
  • ArcGIS Engine
  • ArcMap

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic