BUG

Legend frame in the jspviewer sample does not refresh

Last Published: April 25, 2020

Description

The legend frame in the jspviewer sample does not refresh correctly when using the zoom and identify tools. A blank image is sometimes returned instead of the legend. This issue can occur in the following scenarios:- ArcIMS 9.0, without Service Pack 2, is installed on Windows XP SP2, OR
- ArcIMS 9.0, with Service Pack 2, is installed on Windows XP SP2 and the servlet engine is Tomcat.

Cause

The arcims_jconnect.jar file that is being used by the jspviewer sample is not the most current version.

Workaround

This problem is resolved with an updated version of arcims_jconnect.jar that is installed with ArcIMS 9.0 Service Pack 2. Complete the following steps to verify the file is up to date:

Install ArcIMS 9.0 Service Pack 2 if it has not been installed. A link to ArcIMS Sevice Pack 2 can be found by way of the Related Information section below.

If the problem still occurs and ArcIMS 9.0 Service Pack 2 has been installed on a machine that is using Tomcat as a servlet engine, perform the following:

1. Stop the Tomcat service.
2. Navigate to <Tomcat Install Directory>\webapps and delete the \jspviewer folder.
3. Start the Tomcat service.

Note:
The \jspviewer folder is re-created with the most current files.

Article ID:000007538

Software:
  • Legacy Products

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic