BUG

Errors encountered when using hyperlinks with ArcReader version 9.2 on Solaris or Linux platforms in 'Multi-user' mode

Last Published: April 25, 2020

Description

Errors may be encountered when using hyperlinks with ArcReader version 9.2 on Solaris or Linux platforms. These problems only occur if the product was installed using 'multi-user' (enterprise) mode. When a hyperlink is activated, a pop-up error box may appear indicating that 'iexplorer' could not be found.

Cause

These problems occur if the product was installed using 'multi-user' (enterprise) mode.

Workaround

Download the file at the following link: iexplorer.sh, and place the script in the 'arcgis/bin' folder.

Rename 'iexplorer.sh' to 'iexplorer' (no extension) and make sure the script has 'execute' permissions.

Hyperlinks should function normally once this script has been copied to and renamed in the 'arcgis/bin' directory.

One additional problem may still be encountered when using this workaround. Even though the hyperlinks work properly, a pop-up error message may still appear indicating a problem occurred when accessing the hyperlink. If the hyperlink window opened properly and is functioning normally, these spurious pop-up errors can be ignored.

Article ID:000010023

Software:
  • ArcReader 9 x

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic