BUG

BUG-000167282: Esri curated content is missing after upgrading Portal for ArcGIS

Last Published: November 8, 2024

Description

After upgrading to Portal for ArcGIS 11.2 or 11.3, some users have encountered issues with missing Esri curated content. This article is designed to help identify the issue and provide a path to resolution.

Cause

During an upgrade, the latest Esri curated content is deployed. In some cases, there is a failure to deploy this content during an upgrade, resulting in missing Esri content. The missing content consists of a variety of item types. The following list offers examples, but is not meant to be exhaustive.

Example Item Types:

  • Web Map (e.g., Esri basemap items)
  • Web Scenes
  • Web Mapping Application
  • 2D and 3D Styles
  • Layer Templates

Here are some examples of how you will see the impact of the missing content in Portal for ArcGIS.

Example 1: Missing Web Map items

Map Viewer, Map Viewer Classic, and Scene Viewer fail to return any Esri default basemaps in the basemap gallery widget.

Example 2: Missing Layer Template items

When navigating to Content > New Item > Feature Layer > Use a template, no templates are listed in the dialog box.

Workaround

This issue has been resolved at ArcGIS Enterprise 11.4. If upgrading to version 11.4 is not an option, please contact Esri technical support and reference BUG-000167282 in the case notes. Support analysts will provide a command line utility to restore the missing content. 

Article ID: 000034132

Software:
  • ArcGIS Enterprise

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