BUG

3D Web Styles do not display in the Scene Viewer application in ArcGIS Enterprise 10.9 after installing the Web Styles setup or ArcGIS Enterprise Builder

Last Published: May 19, 2021

Description

In ArcGIS Enterprise, to get the complete set of 3D symbology within the Scene Viewer application it is necessary to install the Web Styles Setup on the same machine running Portal for ArcGIS (when installing with the ArcGIS Enterprise Builder, the Web Styles Setup is automatically installed). After installing the 10.9 Web Styles Setup or 10.9 ArcGIS Enterprise Builder, some of the 3D symbols may not display correctly within the Scene Viewer application.

Cause

This issue is caused by a typo in a file located in the Portal for ArcGIS installation directory (BUG-000139952).

Workaround

  1. After installing the 10.9 Web Styles Setup or 10.9 ArcGIS Enterprise Builder, navigate to the following directory within the Portal for ArcGIS installation directory: …\ArcGIS\Portal\framework\template\
    • Default location on Windows: C:\Program Files\ArcGIS\Portal\framework\template
  2. Open the portal_install_tokens.txt file in a text editor.
  3. Note the last line within the text file. The image below shows the line in question. It reads:
/filetokens/framework/webapps/arcgis#styleItems//filetokens/framework/webapps/arcgis#styleItems/webstyles_tokens.txt
screenshot1.png
  1. Modify this line to read:
/filetokens/framework/webapps/arcgis#styleItems/webstyles_tokens.txt
The image below shows the modified line: screenshot2.png
  1. Save the portal_install_tokens.txt file.
  2. Restart the Portal for ArcGIS system service.

Article ID:000025644

Software:
  • ArcGIS Server
  • ArcGIS Enterprise Builder

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic