BUG

BIM Cloud Connection downloads Revit file as an unsupported file

Last Published: January 22, 2021

Description

BIM Cloud Connection zips files when downloading them from BIM 360. Because of this, ArcGIS Pro cannot directly read the file and display a message of an unsupported file. This behavior only happens when the following criteria are met.

  • The Revit file is linked.
    • BIM 360 is using the design and collaboration function.
  • The total size of the Revit file plus the linked files is at or over the max limit.

Cause

BIM Cloud Connection zips files by mistake.

Workaround

Esri is working to find a solution in the next release. In the meantime, please use the following as a workaround.

  1. Close ArcGIS Pro.
  2. Using File Explorer navigate to the folder where the BIM Cloud Connection downloaded the Revit file.
  3. Change the extension of the Revit file from .RVT to .ZIP
image of downloaded file

image of renamed file
  1. Extract the data from the folder. The folder contains all the linked files associated to the main downloaded file.
image of extracted files

Using the Get Status command

  • The Get Status works as designed.

Using the Refresh from Source command

  • The refresh command works, but downloaded data is again in the .zip format with an .rvt extension. To resolve this issue, follow the steps outlined above in the workaround

Article ID:000024968

Software:
  • ArcGIS Pro 2 7 x
  • ArcGIS Pro 2 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options