PROBLEM

ArcGIS StoryMaps stops responding and does not load when opened from the Portal for ArcGIS App Launcher

Last Published: March 24, 2021

Description

This issue may be encountered after upgrading from ArcGIS Enterprise 10.6.1 to 10.8.1. ArcGIS StoryMaps stops responding and does not load when opened from the Portal for ArcGIS App Launcher.
 

Cause

When compared to a working environment, there are some extra forward slashes (/) on some lines on the StoryMap config.json file.

This file is located in:

C:\Program Files\ArcGIS\Portal\apps\storymaps\static\config.json

Solution or Workaround

  1. After taking a snapshot, update the file by deleting the extra forward slashes from three lines of the story map config file, as shown in the image below.
  2. Navigate to: C:\Program Files\ArcGIS\Portal\apps\storymaps\static\config.json and open the file in a text editor, such as Notepad ++.

config.json file

  1. In the image above of the config file, lines 26, 27 and 28 have an extra forward slash highlighted in the URL (/) after portal . These are the ones to be deleted.
    For example, on line 26, we see:
"ARSGIS_JS_API_URL": "https://<domain>/portal//jsapi/jsapi4/",
  1. After deleting the extra slashes, save the config file.
  2. One should now be able to launch ArcGIS StoryMaps from the App Launcher, unless there are other underlying issues in the deployment.

Article ID: 000024953

Software:
  • ArcGIS Server

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