Description
ArcGIS Pro can be authorized using one of three options: the Named User (NU), Concurrent Use (CU) or Single Use (SU) license. On a machine that is completely disconnected from the Internet or any other machine, authorization using the SU licensing is the only option. It requires the user to create a file that can be uploaded or emailed to Esri from a machine that has internet access. The server sends an authorization file in response. This file can then be used to complete the authorization process on the disconnected machine.
Cause
The authorization process cannot be completed because the authorize.txt file generated from the ArcGIS Pro Software Authorization Wizard is blank.
Steps to Reproduce
- Start ArcGIS Pro. If just installed and started for the first time, Pro starts with the Named User licensing type.
- Click on the Configure Licensing option at the bottom of the sign-in dialog. This displays the Configure Authorization dialog.
- Click the drop-down menu for License Type. Select Single Use License.
- Click the Authorize button to start the Software Authorization Wizard.
- For Authorization Options, select the first option if you have an ArcGIS Pro SU authorization number. You must provide all necessary information. If you have a provisioning file, select the third option, I have received an authorization file and am now ready to finish the authorization wizard. For this example, we assume there is a provisioning file and the third option is used. Browse to the provisioning file and click Next.
- For Authorization Method, select the option, Authorize at Esri’s website or by email to receive your authorization file. Click Next.
- For Authorization Information, verify all requested information is correct and click Next.
- For Software Authorization Number, fill in the ESU number from the provisioning file. Click Next.
- For Authorize Software Extensions, all extension licenses should be filled in from the provisioning file as well, unless the extension is not licensed. Click Next.
- For Email Authorization, click Save to save the authorize.txt file.
Note the instruction to upload the file to My Esri’s secured website or email the file to authorize@esri.com. This is where the bug occurs.
The authorize.txt file should have information about the licenses being authorized, instead, it creates an empty file with just a forward slash (/) in it. Uploading the file to My Esri’s secured website or sending an email to authorize@esri.com results with a failure message. As a result, the authorization process cannot be completed.
Workaround
Install the ArcGIS Pro 3.1.2 Patch when it becomes available on May 25, 2023*.
In the meantime, use the following workaround:
- Install ArcGIS Pro 3.0. Run through the same process to authorize Pro Single Use licenses.
- Once authorized, upgrade to Pro 3.1. The existing authorized Single Use license will work for Pro 3.1.
*Projected release date is subject to change.