DEPRECATION

ArcGIS Maps SDK for Java Deprecation Notice: Support for Java 11

Last Published: June 7, 2023

Description

Support for use of the Java 11 (LTS) language and runtime platform with the ArcGIS Maps SDK for Java is deprecated. The last release to support Java 11 (LTS) is version 200.1 (April, 2023). A minimum of Java 17 (LTS) will be required at the next release, 200.2 (August, 2023). 

Recommendation

If targeting Java LTS versions, update to the current Java 17 (LTS). Start planning to update to Java 21 (LTS). 

Article ID:000030673

Software:
  • ArcGIS Maps SDK for Java

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic