PROBLEM

ArcGIS Flight fails Camera Check with focus or calibration error when using the DJI M300 drone and P1 camera

Last Published: December 10, 2024

Description

ArcGIS Flight fails the System Checks and displays an error message on the Camera Check section stating a lens calibration is required. ArcGIS Flight is unable to clear this error message since the calibration can only be completed using the DJI Pilot 2 app.

Cause

When the DJI M300 drone is connected to the ArcGIS Flight app, a 'Lens calibration required' error message is displayed during the System Checks process if the installed P1 camera was not properly calibrated, or if it was affected during transportation.

Solution or Workaround

Lens calibration is required to clear this error message, allowing the DJI M300 drone to fly using the ArcGIS Flight app.

Steps on how to perform a camera lens calibration using the DJI Pilot 2 app:

  1. Disconnect the iPad cable from the controller.
  2. Open the DJI Pilot 2 app and select the camera settings.
  3. Scroll down and select Calibrate the lens.
  4. Select Calibrate now.
  5. Take off manually with the DJI Pilot 2 app.
  6. Elevate the drone to an altitude of 335 feet (100m) or higher.
  7. Move the camera to -90 degrees (nadir).
  8. Tap on the screen on a point of interest on the video feed.
  9. Tap Calibrate.
  10. Exit lens calibration and return to base.
  11. Reboot the drone and controller.
  12. Reconnect the iPad and test the drone with a new mission to see if the System Checks are cleared.

Article ID: 000030137

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