PROBLEM

ArcGIS Flight and Freefly Astro connection

Last Published: December 10, 2024

Description

ArcGIS Flight system check fails when using a Freefly Astro drone and iPad with a cellular connection. 

Cause

The ArcGIS Flight app communicates wirelessly to Astro drones through its local network. Cellular model iPads may experience communication issues if Flight doesn’t have access to the drone’s local network and may report the wrong details during system checks, which could prevent the drone from flying.

Solution or Workaround

  1. Go to the iPad’s settings.
  2. Scroll down to find the ArcGIS Flight app.
  3. Under Allow ArcGIS Flight To Access, enable Local Network.
  4. Go back to the ArcGIS Flight app. 
  5. A new window appears asking to give Flight access to your device’s local network.
  6. Tap Accept.

If you continue experiencing connection issues, reset your iPad’s network settings: Settings > General > Transfer or Reset (Device) > Reset > Reset Network Settings, or contact Freefly technical support for further instructions. 

Article ID: 000030131

Software:
  • Mobile Applications

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options