BUG

ArcGIS Enterprise 10.5 fails to upgrade correctly if the domain account used to run the server is in UPN format

Last Published: April 25, 2020

Description

When installing ArcGIS Enterprise products, it is possible to list a domain user to run the Datastore, Server, or Portal services. If this format is specified (using the down level domain format - domain/user), the installation and future upgrades proceed as expected.

Additionally, it is possible to specify the UPN (user@domain.com) format to run services via Microsoft Management Console > Services. However, upgrades of Enterprise products do not proceed as expected when using the UPN format.

Cause

This is a known limit. The following bugs have been logged regarding this behavior.

  • BUG-000103854 : ArcGIS GIS Server fails to update properly when a domain account used to run Server uses a User Principal name (UPN) format.
  • BUG-000103899 : Portal for ArcGIS fails to update properly when a domain account used to run Server uses user principal name (UPN) format.
  • BUG-000103853 : ArcGIS Data Store fails to update properly when a domain account used to run the ArcGIS Data store uses a User-Principal-Name (UPN) format.
  • BUG-000103710 : The Configure ArcGIS Server Account utility does not recognize User Prinicipal Name (UPN) formats as domain users.

Workaround

When using a domain account to run ArcGIS Enterprise, use the down level domain format - domain/user. The screenshot below shows the correct way the user account should be configured.

User-added image

The screenshot below shows the configuration that is NOT recommended.

User-added image

For more information on UPN and down level domain formats, please view the Microsoft documentation linked below in the Related Information section.

Article ID:000015676

Software:
  • ArcGIS Server

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