PROBLEM

Unable to create a file geodatabase using a mapped drive in ArcGIS Pro

Last Published: August 20, 2025

Description

When a folder is shared to an organization, for example, //servername/datadir/data/workdir, and the folder is mapped as a new drive in local machine, for example, Z:/data/workdir, the file geodatabase cannot be created using ArcGIS Pro. Additionally,

  • When attempting to create the file geodatabase, the process gets directed to renaming the folder without any .gdb file being created, as shown in the next two images.

Screenshot 2024-12-12 125525.png

Screenshot 2024-12-12 125653.png

  • A feature class cannot be created either, as shown in the next image.

Screenshot 2024-12-12 151422.png

Cause

  • The mapped drive path was being used while accessing the shared folder.
  • The created file geodatabase is not updated to the actual shared location as it is mapped locally in the machine (Z:). This in turn creates a broken geodatabase, as well as faulted feature datasets or feature classes.

Solution or Workaround

  1. Open a project in ArcGIS Pro.
  2. Check if the Catalog pane is enabled or not. If not, enable the catalog pane from View > Catalog Pane.
  3. Right-click the folder and click Add Folder Connection.
  4. In the ribbon, add the actual shared path (//servername/datadir/data/) instead of mapped path (Z:/datadir/data).
  5. Click on the folder to be added.
  6. Create the file geodatabase and feature dataset/classes.

Recommendation

Save the project to create an index for the added folders. This index makes accessibility of the folders faster.

Article ID: 000034367

Software:
  • ArcGIS Pro

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