Description
After a successful upgrade from ArcGIS Server 9.x to ArcGIS Server 10 on Windows, logs no longer display in ArcGIS Server Manager.
Cause
At ArcGIS 10, log files are written to a different location than they were at previous versions of ArcGIS Server. However, the process of upgrading ArcGIS Server does not update the reference location of the log files. ArcGIS Server 10 cannot read log files generated by ArcGIS Server 9.x, and it does not attempt to parse logs if it finds older versions of the files in the log directory.
Workaround
There are two possible solutions to this issue at ArcGIS 10.
Warning:
Do not change the internal ArcGIS Server configuration file, server.dat, to reflect the new log location. When the ArcGIS Server Object Manager is restarted the changes will be discarded. Instead, use either ArcCatalog or ArcGIS Server Manager to make this change.
- Edit the ArcGIS Server log location. This can be done through either ArcCatalog or ArcGIS Server Manager.
ArcCatalog
1. Create an administrative connection from ArcCatalog to ArcGIS Server.
2. Right-click the administrative connection, and select Server Properties.
3. Select the General tab.
4. Change the log file path to point to the proper log location:
(ArcGIS Server installation location)\Server10.0\server\user\log\
ArcGIS Server Manager
1. Log into ArcGIS Server Manager
2. On the left of the window, click GIS Server.
3. Select Log Files.
4. In the Server Activity log, select Server Log Properties.
5. Change the log file path to point to the proper log location:
(ArcGIS Server installation location)\Server10.0\server\user\log\
- Remove the previous ArcGIS version's log files from the old ArcGIS log location at (ArcGIS Server installation location)\server\user\log\. When the server object manager service is restarted, logs are written to this location and can be accessed by the server manager.