PROBLEM

A table created in a PostgreSQL database is not visible in ArcGIS Pro

Last Published: March 26, 2024

Description

In PostgreSQL, a table is created with a unique ID field. The table is stored in a schema owned by a login user with the same name as the schema. In pgAdmin, the table is visible and can be queried. In the example shown in the image of pgAdmin below, this table is called "TESTTABLE".

2024-03-08_11-12-22.png

However in ArcGIS Pro, the new table is not visible, even when connecting the PostgreSQL database as the owner of the table, as shown in the next image.

2024-03-08_11-24-40.png

Cause

The table name has uppercase characters. In PostgreSQL, using uppercase or mixed-case characters in table names requires that all queries be constructed with double quotes. This is not supported in ArcGIS for PostgreSQL. When connecting to a PostgreSQL database from ArcGIS Pro, tables using upper or mixed-case characters are not visible. 

Solution or Workaround

Change the table name to all lowercase. 

2024-03-08_11-30-20.png

 

2024-03-08_11-30-47.png

Article ID: 000032184

Software:
  • ArcGIS Pro
  • Enterprise

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