laptop and a wrench

Bug

When deleting or editing server directories, notify the user when it is being used by existing services.

Last Published: August 25, 2014 No Product Found
Bug ID Number NIM012592
SubmittedOctober 25, 2007
Last ModifiedJune 5, 2024
Applies toNo Product Found
Version found9.2
Version Fixed9.3
StatusFixed

Description

The virtual output directory can be changed in an admin connection to an ArcGIS server in ArcCatalog. This change should be applied automatically to all services that were defined to use the previous virtual output directory. For geodata services, however, the change is not being applied and this is a software defect.

This can cause operations on a geodata service to fail, since the old virtual output directory may no longer be valid. For example, creating or synchronizing a replica may fail with an internet connection due to this problem.

Cause

This is a software defect.

Workaround

To workaround this problem, reset the output directory for each geodata service. To reset the output directory:

  1. From an admin connection in ArcCatalog, stop the geodata service.
  2. Right-click the service. Select service properties.
  3. Click the Parameters tab.
  4. Change the output directory to none. Click apply.
  5. Change the output directory back to what it was before step 4. Click apply.
  6. Restart the service. Now, it uses the virtual output directory.

Steps to Reproduce

Bug ID: NIM012592

Software:

  • No Product Found

Get notified when the status of a bug changes

Download the Esri Support App

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options