laptop and a wrench

Bug

Upgrading some Samsung Android devices to Android OS version 7.x does not allow users to open an existing web map unless a factory reset is performed on the device and Collector for ArcGIS is reinstalled.

Last Published: July 26, 2021 Collector Classic for ArcGIS (Android)
Bug ID Number BUG-000106355
SubmittedJuly 6, 2017
Last ModifiedApril 2, 2025
Applies toCollector Classic for ArcGIS (Android)
Version found17.0.2
Operating SystemAndroid
Operating System Version7.0x
StatusWill Not Be Addressed

Description

When upgrading certain Android devices to version 7.x, existing web maps no longer launch successfully on the Collector for ArcGIS app. Additionally, when attempting to launch a web map, including the freely available 'Try it' maps, the map launches but loading does not complete. The layers and basemaps do not render.

Cause

This is a known issue. Upgrading on some Samsung Android devices may render users unable to open existing web maps unless a factory reset is performed on the device and Collector for ArcGIS is reinstalled. The issue is not due to incompatibility with Android 7.x, as the version of the Android OS is fully supported by the Collector for ArcGIS app.

The following is a list of Android devices that have reportedly exhibited this behavior after upgrading to Android 7.x:

  • Samsung Galaxy Tab A
  • Samsung Galaxy Tab S2
  • Samsung Galaxy Note 4
Note:
Other types of Android devices may also experience this behavior.

Workaround

Warning:   
Before proceeding with the following workaround, back up valuable data or information on the device. This information is deleted from the device when a factory reset is performed.
  1. Ensure all offline edits from Collector for ArcGIS have been synchronized successfully.
  2. Back up existing offline maps.
    1. Connect the Android device to a PC via a USB cable.
    2. In Windows Explorer, navigate to the device and locate the ArcGIS_Collector folder.
    3. Copy and paste the entire folder onto the desktop of the PC. This is the backup folder.
  3. Perform a complete factory reset, following the steps outlined in the documentation for the device in use.
  4. After completing the reset, reinstall Collector for ArcGIS.
  5. Restore existing offline maps:
    1. Connect the Android device to a PC via a USB cable.
    2. In Windows Explorer, navigate to the device.
    3. Copy and paste the ArcGIS_Collector folder from Step 2 back onto the device's internal storage.
  6. Launch Collector for ArcGIS.

Steps to Reproduce

Bug ID: BUG-000106355

Software:

  • Collector Classic for ArcGIS (Android)

Get notified when the status of a bug changes

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options