laptop and a wrench

Bug

Upgrading some ArcGIS Online trials to full subscription results in the hosted feature services being unable to be queried and sometimes prevents the organization from utilizing any analysis services.

Last Published: December 21, 2018 ArcGIS Online
Bug ID Number BUG-000115487
SubmittedJuly 19, 2018
Last ModifiedMay 31, 2023
Applies toArcGIS Online
Version found6.2
Operating SystemN/A
Operating System VersionN/A
StatusNon-Reproducible

Description

When a client has a trial ArcGIS Online account and decides to upgrade to a full paid subscription ArcGIS Online plan while requesting to retain their published content; a failure can occur in some rare cases where the hosted feature services are unable to be accessed via the map viewer or in the layer's attribute table.
Map Viewer error: "The layer <layerName> did not draw completely"

Attribute table: "Data Error"


Content can still be published successfully from ArcGIS Pro, however it cannot be visualised in ArcGIS Online.

This may occur only for particular feature services, or for all content in the client's ArcGIS Online portal.

Cause

There has been a sync failure during the subscription upgrade that may require a manual reset at the feature service level or requisitioning a Tech Assist to conduct a subscription manual reset.

Workaround

1. Troubleshoot
  • go to the admin rest endpoint for the feature(s)
    • click "reset"
    • navigate back to ArcGIS Online to see if we can interact with the content normally
      • if yes, carry out this workflow for all hosted feature services behaving this way
  • if not, publish new content to ArcGIS Online
    • navigate back to ArcGIS Online to see if we can interact with the content normally
      • is yes, re-publish old services and re-configure them with existing web maps/applications
  • if not;
2. Request Tech Assist
  • Provide a thorough description of the issue, including screenshots and troubleshooting and request that a manual reset be carried out by the Operations Team. Reference any other cases found in Salesforce which reflect the same issue and where a manual reset has helped get clients back up and running with their data carried over from their previous trial licenses.

Steps to Reproduce

Bug ID: BUG-000115487

Software:

  • ArcGIS Online

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