Unable to upgrade geodatabase on an ArcSDE database server if connecting to a 9.2 database server from a 9.3 client using the 9.2 direct connect driver.
Last Published: August 25, 2014No Product Found
Bug ID Number
NIM036617
Submitted
July 8, 2008
Last Modified
June 5, 2024
Applies to
No Product Found
Version found
9.3
Status
Duplicate
The issue is a duplicate of an existing issue. See the issue's Additional Information section for details. Customers associated with the duplicate issue are automatically attached to the open issue.
Description
When the pre-9.3 geodatabase direct connect drivers are installed on an ArcGIS Desktop 9.3 client and a connection is made to an ArcSDE 9.2 geodatabase in SQL Server Express, the geodatabase cannot be upgraded. The following error message is returned when the Upgrade Geodatabase button in the Geodatabase Properties dialog box is clicked:
"Upgrade geodatabase failed. Active connections found during upgrade."
Cause
With the direct connect drivers installed, the client application connects to the geodatabase. However, if there are any connections to the geodatabase, it cannot be upgraded.
Workaround
Uninstall the pre-9.3 geodatabase direct connect drivers and connect from the ArcGIS Desktop 9.3 client to the ArcSDE 9.2 geodatabase on SQL Server Express. Without the direct connect driver, the connection cannot be made and an upgrade prompt appears. Click Yes when prompted to upgrade.