laptop and a wrench

Bug

The 'Table to Table' tool fails in ModelBuilder if the input is a query layer.

Last Published: March 3, 2016 ArcGIS for Desktop
Bug ID Number BUG-000088138
SubmittedJune 5, 2015
Last ModifiedMay 5, 2023
Applies toArcGIS for Desktop
Version found10.3
StatusWill Not Be Addressed

Additional Information

We apologize that we were unable to address this issue within the current product support cycle. If the issue continues to affect your work in a supported release, please contact Technical Support. Note that ArcGIS 10.8.2 is the current release of ArcGIS Desktop and will enter Mature Support in March 2024 (https://support.esri.com/en-us/products/arcmap/life-cycle). There are no plans to release an ArcGIS Desktop 10.9, and we recommend that you migrate to ArcGIS Pro. See Migrate from ArcMap to ArcGIS Pro (https://www.esri.com/en-us/arcgis/products/arcgis-pro/resources/migrate) for more information.

Workaround

  1. In ArcMap, File > Add Data > Add Query Layer > use same syntax
  2. Launch the Table to Table tool and choose the in-map query layer as input
  3. Execute this and the Table to Table works successfully

The 'Add Query Layer' from File > Add Data seems to have full functionality where the tool 'Make Query Layer' has limited functionality, especially within Model Builder. This 'Add Query Layer' is not a tool that is available in Python or the standard Toolbox so it is not available to use in Model Builder.

Steps to Reproduce

Bug ID: BUG-000088138

Software:

  • ArcGIS for Desktop

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic