The sdesetup command with SQL Server should not allow a lower-release version to be executed against a higher release of the ArcSDE instance.
Last Published: August 25, 2014No Product Found
Bug ID Number
NIM012687
Submitted
October 31, 2007
Last Modified
June 5, 2024
Applies to
No Product Found
Version found
9.3
Version Fixed
9.3
Status
Fixed
The bug has been fixed. See the Version Fixed and Additional Information, if applicable, for more information.
Description
When connecting from an ArcGIS Desktop 9.2 client to an ArcSDE 9.3 geodatabase for SQL Server Express, server administrators are able to downgrade the version 9.3 geodatabase.
Cause
Because connections to ArcSDE geodatabases for SQL Server Express are always direct connections, ArcGIS Desktop checks the release number of the geodatabase and compares it to the release number of the direct connect libraries being used by the connecting client. When these are incompatible, the user is prompted to upgrade.
Due to a bug in sdesetup, the 'upgrade' succeeds in changing the ArcSDE 9.3 geodatabase to an ArcSDE 9.2 geodatabase.
The bug in sdesetup that was allowing the client to downgrade the geodatabase was fixed in ArcGIS Desktop 9.2 Service Pack 4 (SP4), however, the prompt still appears in this configuration (SP4).
Workaround
This was fixed in ArcGIS 9.2, Service Pack 6. Upgrade any Desktop clients that connect to the ArcSDE SQLServer Express geodatabase to SP6 to eliminate the possibility that an administrative user could downgrade the geodatabase. See the link in the related section for the Service Pack downloads page.