The ArcGIS Desktop print dialog box crashes when clicking the setup button in an Engine application.
Last Published: August 25, 2014No Product Found
Bug ID Number
NIM059755
Submitted
August 5, 2010
Last Modified
June 5, 2024
Applies to
No Product Found
Version found
10.1
Version Fixed
10.1
Status
Fixed
The bug has been fixed. See the Version Fixed and Additional Information, if applicable, for more information.
Description
Clicking the setup button on the Print Dialog crashes an ArcGIS Engine application.
This issue is only reproducible in an ArcGIS Engine application that binds to a Desktop runtime and uses the Desktop Print Dialog.
Cause
The ArcGIS Desktop Print Dialog has a dependency on some Desktop only functionality. Clicking the setup button attempts to initialize the Desktop only functionality and causes the application to crash.
The fix corrects the dependency and bypasses the functionality when using the dialog in ArcGIS Engine.
Workaround
The following patch has been provided as a solution. This patch is for ArcGIS Desktop version 10.0 and is superseded by 10.0 Service Pack 1. Only install this patch if an ArcGIS Engine application is running that binds to the ArcGIS Desktop runtime and uses the ArcGIS Desktop Print Dialog.
Download the Print Dialog Patch and unzip the file.
Review the instructions in the QFE-DT-10-164907.doc to apply the patch.