laptop and a wrench

Bug

The ArcGIS Desktop print dialog box crashes when clicking the setup button in an Engine application.

Last Published: August 25, 2014 No Product Found
Bug ID Number NIM059755
SubmittedAugust 5, 2010
Last ModifiedJune 5, 2024
Applies toNo Product Found
Version found10.1
Version Fixed10.1
StatusFixed

Description

Clicking the setup button on the Print Dialog crashes an ArcGIS Engine application.

This issue is only reproducible in an ArcGIS Engine application that binds to a Desktop runtime and uses the Desktop Print Dialog.

Cause

The ArcGIS Desktop Print Dialog has a dependency on some Desktop only functionality. Clicking the setup button attempts to initialize the Desktop only functionality and causes the application to crash.

The fix corrects the dependency and bypasses the functionality when using the dialog in ArcGIS Engine.

Workaround

The following patch has been provided as a solution. This patch is for ArcGIS Desktop version 10.0 and is superseded by 10.0 Service Pack 1. Only install this patch if an ArcGIS Engine application is running that binds to the ArcGIS Desktop runtime and uses the ArcGIS Desktop Print Dialog.

  1. Download the Print Dialog Patch and unzip the file.
  2. Review the instructions in the QFE-DT-10-164907.doc to apply the patch.

Steps to Reproduce

Bug ID: NIM059755

Software:

  • No Product Found

Get notified when the status of a bug changes

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options