Remote Desktop connection breaks the License Manager that was shipped with 9.2.
Last Published: August 25, 2014No Product Found
Bug ID Number
NIM003635
Submitted
August 5, 2006
Last Modified
December 12, 2024
Applies to
No Product Found
Version found
9.2
Version Fixed
9.3
Status
Fixed
The bug has been fixed. See the Version Fixed and Additional Information, if applicable, for more information.
Description
Using Remote Desktop to access the ArcGIS 9.2 License Server (the machine running the ArcGIS License Manager), results in failure to detect the USB hardware key. The following error is returned:
"The SuperPro driver appears to be installed and running. However, the hardware key does not appear to be plugged into a parallel port on this system."
Cause
This is a known issue with ArcGIS License Manager version 9.2.
The use of Windows Remote Desktop to connect to a License Server results in the Sentinel driver being unable to detect the hardware key, which causes the License Manager Service to stop.
Workaround
Disconnect from Remote Desktop and restart the ArcGIS License Manager locally on the server.
Uninstall the 9.2 ArcGIS License Manager and the Sentinel Protection Installer with add/remove programs, and install the ArcGIS 9.3 License Manager linked below in Related Information. The 9.3 version uses a different sentinel driver and is not effected by Remote Desktop in the same way.