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Bug

Esri curated content is missing after upgrading Portal for ArcGIS.

Portal for ArcGIS
Bug ID Number BUG-000167282
SubmittedMay 7, 2024
Last ModifiedAugust 28, 2025
Applies toPortal for ArcGIS
Version found11.2
Operating SystemN/A
Operating System VersionN/A
Version Fixed11.4
StatusFixed

Description

After upgrading to Portal for ArcGIS 11.2 or 11.3, some users have encountered issues with missing Esri curated content. This article is designed to help identify the issue and provide a path to resolution. This issue has been resolved at ArcGIS Enterprise 11.4. If upgrading to version 11.4 is not an option, Esri has created a script to reset the Esri curated content.  

Cause

During an upgrade, the latest Esri curated content is deployed. In some cases, there is a failure to deploy this content during an upgrade, resulting in missing Esri content. The missing content consists of a variety of item types. The following list offers examples, but is not meant to be exhaustive.

Example Item Types:

  • Web Map (e.g., Esri basemap items)
  • Web Scenes
  • Web Mapping Application
  • 2D and 3D Styles
  • Layer Templates

Here are some examples of how you will see the impact of the missing content in Portal for ArcGIS.

Example 1: Missing Web Map items

Map Viewer, Map Viewer Classic, and Scene Viewer fail to return any Esri default basemaps in the basemap gallery widget.

Example 2: Missing Layer Template items

When navigating to Content > New Item > Feature Layer > Use a template, no templates are listed in the dialog box.

Workaround

These steps describe running the reset Esri content utility to restore missing Esri content resulting from BUG-000167282.

Note:
For highly available ArcGIS Enterprise deployments run the reset Esri content utility on the primary Portal for ArcGIS machine. Ensure the account used to run the utility has write access to the Portal for ArcGIS content directory (e.g. C:\arcgisportal\content).

Portal for ArcGIS – Windows 

  1. Access the machine where Portal for ArcGIS is installed.
  2. Download the resetesricontentutility (Windows).zip file.
  3. Extract the .zip file to a temporary location.
  4. Copy the extracted resetesricontentutility folder to the Portal for ArcGIS installation, tools directory, for example:  <Portal for ArcGIS installation location>\tools.
  5. Open a command prompt and navigate to the Portal for ArcGIS installation, tools directory, for example, cd C:\Program Files\ArcGIS\Portal\tools.
  6. Run the following command to execute the reset Esri content utility:
resetesricontentutility.bat
Note:
As the tool runs it may write WARNING messages to the console. These WARNING messages are expected and can be disregarded.
  1. When prompted, provide your Portal for ArcGIS administrator credentials.
  2. Once completed, the tool will write an “End of reset content procedure” message to the console.

Example: 

End of Reset Content procedure at: <time stamp> Reset Content procedure took: <x> seconds 

Portal for ArcGIS – Linux

  1. Access the machine where Portal for ArcGIS is installed.
  2. Download the resetesricontentutility (Linux).zip file.
  3. Extract the .zip file to a temporary location.
  4. Copy the extracted resetesricontentutility folder to the Portal for ArcGIS installation, tools directory, for example, <Portal for ArcGIS installation location>\tools.
  5. Navigate to the Portal for ArcGIS installation, tools directory, for example,  cd /data/arcgis/portal/tools.
  6. Run the following command to execute the reset Esri content utility
./resetesricontentutility.sh
Note:
As the tool runs it may write WARNING messages to the console. These WARNING messages are expected and can be disregarded.
  1. When prompted, provide your Portal for ArcGIS administrator credentials.
  2. Once completed, the tool will write an “End of reset content procedure” message to the console.

Example: 

End of Reset Content procedure at: <time stamp> Reset Content procedure took: <x> seconds

Additional Information

This tool is supported at Portal for ArcGIS 11.2 and 11.3 as these versions are affected by BUG-0001672828. If you encounter any issues while running the reset Esri content utility or the utility does not resolve your issue, please contact Esri technical support.

Steps to Reproduce

Bug ID: BUG-000167282

Software:

  • Portal for ArcGIS

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