laptop and a wrench

Bug

Downloading Revit models that have linked models and design collaboration enabled from the BIM 360 connections in ArcGIS Pro, results in downloading a corrupted Revit file.

Last Published: December 16, 2020 ArcGIS Pro
Bug ID Number BUG-000135961
SubmittedDecember 8, 2020
Last ModifiedDecember 12, 2024
Applies toArcGIS Pro
Version found2.6.3
Operating SystemWindows OS
Operating System Version10.0 64 Bit
Version Fixed2.8
StatusFixed

Description

BIM Cloud Connection zips files when downloading them from BIM 360. Because of this, ArcGIS Pro cannot directly read the file and display a message of an unsupported file. This behavior only happens when the following criteria are met.

  • The Revit file is linked.
    • BIM 360 is using the design and collaboration function.
  • The total size of the Revit file plus the linked files is at or over the max limit.

Cause

BIM Cloud Connection zips files by mistake.

Workaround

Esri is working to find a solution in the next release. In the meantime, please use the following as a workaround.

  1. Close ArcGIS Pro.
  2. Using File Explorer navigate to the folder where the BIM Cloud Connection downloaded the Revit file.
  3. Change the extension of the Revit file from .RVT to .ZIP
image of downloaded file

image of renamed file
  1. Extract the data from the folder. The folder contains all the linked files associated to the main downloaded file.
image of extracted files

Using the Get Status command

  • The Get Status works as designed.

Using the Refresh from Source command

  • The refresh command works, but downloaded data is again in the .zip format with an .rvt extension. To resolve this issue, follow the steps outlined above in the workaround

Steps to Reproduce

Bug ID: BUG-000135961

Software:

  • ArcGIS Pro

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