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Bug

ArcGIS GIS Server is missing data items introduced at 10.5 (raster, cloud and big data file share) after upgrade.

Last Published: March 13, 2017 ArcGIS GIS Server
Bug ID Number BUG-000102518
SubmittedJanuary 30, 2017
Last ModifiedApril 2, 2025
Applies toArcGIS GIS Server
Version found10.5
Version Fixed10.5.1
StatusFixed

Description

After upgrading from an older version of ArcGIS Server to ArcGIS Server 10.5, the ArcGIS Server Manager is unable to register the Big Data File Share, Raster store, or Cloud store as data stores, and the following error message is returned.
Error:   
PARENT_NOT_REGISTERED

Cause

After upgrading from an older version of ArcGIS Server to 10.5, the new data items supported at ArcGIS Enterprise 10.5 (such as the big data file share, raster store, or cloud store) are not registered to ArcGIS Server. Therefore, users are unable to register a big data file share to be used by the GeoAnalytics Server, or a raster store to be used by the Raster Analysis server. Users also cannot register a cloud store if GIS resources and data are stored in Amazon Web Services or Microsoft Azure.

Workaround

Register the big data file share, raster store, and cloud store as data items in the ArcGIS Server Administrator Directory.
  1. Login to the ArcGIS Server Administrator Directory using the administrator account.
  2. Navigate to and select data registerItem.
  3. In the box next to Item, copy and place the following to add the cloud store data item:
{
"path": "/cloudStores",
"type": "datadir"
}
  1. Click Register Item to register the item to ArcGIS Server.
  2. Repeat steps 3 and 4 for the raster store and big data file share:
{
"path": "/rasterStores",
"type": "datadir"
}
{
"path": "/bigDataFileShares",
"type": "datadir"
}
  1. Register the big data file share, raster store, or cloud store as data stores in ArcGIS Server Manager.

Steps to Reproduce

Bug ID: BUG-000102518

Software:

  • ArcGIS GIS Server

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