ArcGIS Desktop Help does not come up anymore in ArcCatalog and ArcMap.
Last Published: August 25, 2014No Product Found
Bug ID Number
NIM010730
Submitted
August 2, 2007
Last Modified
April 2, 2025
Applies to
No Product Found
Version found
9.2
Version Fixed
9.3
Status
Fixed
The bug has been fixed. See the Version Fixed and Additional Information, if applicable, for more information.
Description
The Desktop Help system fails to open when using the Help menu > ArcGIS Desktop Help option in ArcMap or ArcCatalog.
This is limited to the Windows Server 2003 (32-bit) operating system (OS) only, standard installation and all service packs (for example, Windows Server 2003 R2). This issue is not reproducible in other operating systems.
Cause
The Desktop Help system (installed Help) is a merged CHM Help system. To launch a (compiled help system) CHM successfully you need to access the Windows hh.exe file. The Windows Server 2003 32-bit operating system seems to react differently to the hh.exe than other operating systems. The cause has been narrowed down to the following: The software menu does not handle the hh.exe file in a way that supports this OS.
Workaround
There are numerous workarounds for this issue. Any one of the following options successfully launches the Desktop Help:
To open the ArcGIS desktop installed Help: a) Go to Start > Programs > ArcGIS > ArcGIS Desktop Help. b) Create a shortcut on the desktop. Set the location as
..\ArcGIS\Help\ArcInfoMain.chm)
and use it to launch the installed Help.
To open the ArcGIS Desktop Web Help: a) In the applications, click the Help menu > Desktop Help Online b) Go to Start > Programs > ArcGIS > ArcGIS Desktop Help Online.
To open the ArcGIS Desktop Geoprocessing Tool Help: a) In the ArcToolbox window, right-click any toolbox or tool and select Help. This launches the installed Help system.