Bug ID Number |
BUG-000097135 |
Submitted | June 14, 2016 |
Last Modified | April 2, 2025 |
Applies to | Portal for ArcGIS |
Version found | 10.4.1 |
Version Fixed | 10.5 |
Status | Fixed
The bug has been fixed. See the Version Fixed and Additional Information, if applicable, for more information.
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Description
When Portal for ArcGIS and ArcGIS Data Store are installed on non-English locales, the account running the services does not get set properly. No error occurs during the installation; however, the Local System account is used for the service instead of the account specified during installation. Furthermore, permissions are not properly set on the installed folders.
Additionally, running the configureserviceaccount.bat command-line utility to change the ArcGIS Data Store account or Portal for ArcGIS account generates the below error:
Error:
‘Error adding user to local group. RunAs configuration stopped due to an error’
Cause
This is due to the utility that sets the account for the Portal for ArcGIS and the ArcGIS Data Store requiring a group called ‘Users’, found in the Computer Management console. This problem occurs on non-English operating systems that have the ‘Users’ group translated into the respective language.
Workaround
- Add a Windows group called ‘Users’ using the English alphabet to the Computer Management console after the installation completes.
- Open command prompt as an Administrator and run the ‘configureserviceaccount.bat’ utility to properly set the account and privileges.
- For ArcGIS Data Store this is found in the <ArcGIS Data Store installation directory>\tools folder.
- For Portal for ArcGIS this is found in the <Portal for ArcGIS installation directory>\tools\ConfigUtility folder.
Steps to Reproduce