laptop and a wrench

Bug

An error message, "The requested field was not found," is generated when attaching a photo in an offline workflow only using Collector for ArcGIS application.

Last Published: November 18, 2015 Collector Classic for ArcGIS (iOS)
Bug ID Number BUG-000092202
SubmittedNovember 16, 2015
Last ModifiedJune 11, 2020
SeverityMedium
Applies toCollector Classic for ArcGIS (iOS)
Version found10.3.5
Version Fixed10.3.7
StatusFixed

Workaround

This workaround was tested on a small subset of data.1) Copy the feature class in the enterprise geodatabase.2) Add GlobalIDs, enable attachments and version the data.3) Export the original attachments. <a href="http://support.esri.com/ES/knowledgebase/techarticles/detail/41763" target="_blank">http://support.esri.com/ES/knowledgebase/techarticles/detail/41763</a>4) Run Generate Attachment Match Table (Data Management) tool. <a href="http://resources.arcgis.com/EN/HELP/MAIN/10.2/index.html#/Generate_Attachment_Match_Table/001700000157000000/" target="_blank">http://resources.arcgis.com/EN/HELP/MAIN/10.2/index.html#/Generate_Attachment_Match_Table/001700000157000000/</a>5) Run Add Attachments (Data Management) tool. <a href="http://resources.arcgis.com/EN/HELP/MAIN/10.2/index.html#//00170000014v000000" target="_blank">http://resources.arcgis.com/EN/HELP/MAIN/10.2/index.html#//00170000014v000000</a>6) Publish a feature service with Sync enabled.

Steps to Reproduce

Bug ID: BUG-000092202

Software:

  • Collector Classic for ArcGIS (iOS)

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic