laptop and a wrench

Bug

After logging into ArcIMS Administrator, a blank error box shows and then the software hangs.

Last Published: August 25, 2014 No Product Found
Bug ID Number NIM013889
SubmittedDecember 18, 2007
Last ModifiedApril 2, 2025
Applies toNo Product Found
Version found9.2
Version Fixed9.4
StatusFixed

Description

After entering the user name and password to log into the standalone Administrator, a blank dialog box opens and the Administrator window freezes.

Note:
The information in this article applies to retired product ArcIMS.

Cause

If any error or warning messages pop-up during the course of logging into the Administrator, the Administrator window may freeze. This is a known limitation.

The two most common causes of an error or warning message when logging into the Administrator are:

  • An ArcIMS Monitor service associated with the Application Server is not running and therefore one or more ArcIMS Spatial Server containers are not available.
  • ArcIMS license is invalid or expired.

Workaround

The frozen Administrator window can only be closed by ending the process associated with that standalone ArcIMS Administrator application.

On Windows, use the Task Manager end task utility; on Unix/Linux, use commands to terminate the processes associated with Administrator.

To troubleshoot the cause of error/warning messages, follow the steps given below:

  1. Stop ArcIMS.
    1. Go to Control Panel > Administrative Tools > Services.
    2. Stop ArcIMS Tasker.
    3. Stop ArcIMS Monitor.
    4. Stop ArcIMS Application Server.
  2. Enable full logging in ArcIMS Application server by setting debug="true" and logtofile="true" in the AppServer.properties file. This file is located in the directory <arcims_install_location>\ArcGIS\ArcIMS\AppServer on Windows or in the $AIMSHOME/Middleware/Application_Server directory on Unix/Linux.
  3. Start ArcIMS:
    1. Go to Control Panel > Administrative Tools > Services.
    2. Start ArcIMS Application Server.
    3. Start ArcIMS Monitor.
    4. Start ArcIMS Tasker.
  4. Log into the ArcIMS Administrator and reproduce the error condition.
  5. Open the Application Server debug log in a text editor. This log file is located in <arcims_install_location>\ArcGIS\ArcIMS\AppServer\log folder on Windows or in $AIMSHOME/Middleware/Application_Server/log directory on Unix/Linux.
  6. If the error condition is due to a required ArcIMS Monitor not running, the following warning message is logged.
<WARNING code="191" message="[WRN0102] ArcIMS is not available on <machine_name>."/>

To rectify this warning, make sure that ArcIMS Monitor and Spatial Server process are running on all Monitor machines associated with this Application Server.

If the error condition is due to a missing or invalid license, the following error message is logged.

<ERROR code="ERR3001"> ArcIMS on machine: <machine_name> is not authorized.</ERROR>

To rectify this warning, verify that Spatial Server is properly licensed and if necessary, re-run the post-install to update the license.

  1. After fixing the error/warning conditions reported in step 6, restart ArcIMS and log into the Administrator.

Steps to Reproduce

Bug ID: NIM013889

Software:

  • No Product Found

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