laptop and a wrench

Bug

A HTTP 404 error is returned when creating an application from the My Content page in Portal for ArcGIS 10.3.1 using a template.

Last Published: July 5, 2017 Portal for ArcGIS
Bug ID Number BUG-000087735
SubmittedMay 19, 2015
Last ModifiedMay 31, 2023
Applies toPortal for ArcGIS
Version found10.3.1
Version Fixed10.4
StatusFixed

Description

Attempting to open an app created from a configurable app template via 'My Content > Create App > Using a Template' may result in a 404 error.

Cause

This is a known issue.

The ArcGIS Web Adaptor name is missing from the app URL.

Workaround

Option #1

Use an alternative workflow: open the web map in the map viewer and click Share. Select any template in the gallery to configure an app. The app created from this workflow is not impacted by the URL issue discussed in this article. For more information, see the help topic Make your first app.

Option #2

A broken app can be fixed by inserting the Web Adaptor name missing from the URL. The instructions provided describe how to fix the broken app URL.

  1. From the My Contents page, open the Item Details page for the broken app.
  2. Under Properties, note the URL that is displayed. The portion of the URL with the web adaptor name may be missing, similar to the example below:

    https://webadaptorhost.domain.com/apps/Viewer/index.html?appid=84ad30cce2f24d5abd1c5b212239dbc0 


    The URL must include the web adaptor name, as follows:

    https://webadaptorhost.domain.com/<webadaptorname>/apps/Viewer/index.html?appid=84ad30cce2f24d5abd1c5b212239dbc0

  3. Click Edit, and modify the URL property to include the web adaptor name.
  4. Click Save.
  5. To continue configuring the app, click Configure App. To view the app, click Open > View Application.

Steps to Reproduce

Bug ID: BUG-000087735

Software:

  • Portal for ArcGIS

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Discover more on this topic