PROBLEM

Anmelden und Erstellen von neuen Konten in Portal for ArcGIS funktioniert nicht

Last Published: October 14, 2021

Beschreibung

In manchen Fällen schlagen Versuche, sich zum ersten Mal in Portal for ArcGIS anzumelden, fehl, und neue Benutzerkonten können nicht erstellt werden. Wenn das Konto nicht automatisch bei der Anmeldung erstellt wird, können organisationsspezifische Benutzer auf das Portal zugreifen, jedoch nur mit den Berechtigungen eines Benutzers ohne ein ArcGIS Organisationskonto.

Ursache

  • Die Einstellung "enableAutomaticAccountCreation" ist auf "false" festgelegt.
  • ArcGIS Web Adaptor ist nicht korrekt konfiguriert. Zum Beispiel ist die Option "Windows-Authentifizierung" im IIS-Manager (Internetinformationsdienste) deaktiviert.

Lösung oder Problemumgehung

Wählen Sie je nach Ursache eine der Optionen unten, um das Problem zu lösen.

Festlegen der Einstellung "enableAutomaticAccountCreation" auf "true"

  1. Melden Sie sich mit einem Administratorkonto bei der Portaladmin-API an. Beispiel:
https://portal.domain.com:7443/<web adaptor name>/portaladmin
  1. Wählen Sie Security > Config >Update Security Configuration.
  2. Bearbeiten Sie die Konfiguration enableAutomaticAccountCreation, sodass sie auf true gesetzt ist.
  3. Klicken Sie auf Update Configuration.
Die Seite

Ordnungsgemäßes Konfigurieren von ArcGIS Web Adaptor

Konfigurieren Sie ArcGIS Web Adaptor korrekt im IIS-Manager (Internetinformationsdienste). Eine Anleitung dazu finden Sie unter Portal for ArcGIS: Konfigurieren von ArcGIS Web Adaptor zur Verwendung von IWA.

Artikel-ID:000026600

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden