PROBLEM

ArcGIS und VPN: Informationen zu Verbindungsfehlern, Timeouts und Performance-Einbußen beim Remote-Zugriff

Last Published: June 10, 2020

Beschreibung

Die gängigste Methode beim Remote-Zugriff auf die Esri Software ist die Verwendung über VPN, obwohl manchmal auch andere Methoden genutzt werden, wie beispielsweise RDP-Verbindungen (Remote Desktop Protocol). Bei der Arbeit mit ArcGIS Desktop-Anwendungen über eine VPN-Verbindung können Performance-Einbußen auftreten, selbst bei relativ einfachen Operationen, wie dem Erstellen einer neuen Feature-Class und dem Hinzufügen von Feldern, Hinzufügen von Attributregeln oder Kopieren einer wenig umfangreichen Feature-Class von einer Geodatabase in eine andere. Folgende Probleme können auftreten:

  • Langsames Öffnen von ArcMap und ArcGIS Pro
  • Fehlende Features beim Schwenken und Zoomen
  • Langsame Ausführung von Geoverarbeitungswerkzeugen
  • Langsame Neudarstellung von MXDs
  • Lange Reaktionszeiten beim Hinzufügen oder Bearbeiten von Features
  • Beim Hinzufügen eines Layers reagiert ArcMap nicht
  • Lange Darstellungszeiten oder ein ein sich drehendes blaues Symbol

Darüber hinaus können weitere Probleme auftreten, wie unter anderem:

  • Datenbankverbindungsfehler
  • Lizenzmanager-Fehler
  • Latenz beim Öffnen von ArcGIS Server Manager
  • Leere Seiten und andere Browserfehler bei dem Versuch, auf Startseiten und Webkarten des ArcGIS Enterprise-Portals zuzugreifen

In diesem Artikel werden einige häufige Fehlerszenarien beschrieben und verschiedene Methoden vorgestellt, mit denen die Ursache dieser Fehler ermittelt und festgestellt werden kann, ob diese auf Probleme mit dem Router, der Bandbreite, der VPN-Konfiguration oder der Datenbankverbindung zurückzuführen sind. Die Eingrenzung dieser Probleme kann dazu beitragen, eine angemessene Lösung zu finden.

Hinweis: Eine Liste häufig gestellter Fragen zum Remote-Zugriff auf die Esri Technologie im Allgemeinen, wie z. B. die Installation, Autorisierung von Lizenzen usw., finden Sie im Blog von Esri Canada: How to access Esri technology while working from home.

Fehler-Meldungen
Zusätzlich zu den Problemen mit Latenz und Timeouts und ganz allgemein beim Herstellen von Verbindungen, werden eine ganze Reihe von Fehlermeldungen zurückgegeben. Die meisten dieser Probleme treten beim Arbeiten mit ArcGIS-Anwendungen auf, wenn diese mit einem auf einem Netzwerk-Server gehosteten RDBMS verbunden sind. Dies ist beispielsweise der Fall, wenn während der Arbeit in ArcMap oder Pro eine Verbindung zu einer Enterprise-Geodatabase besteht. Außerdem werden möglicherweise Fehlermeldungen zurückgegeben, die darauf hinweisen, dass die Verbindung zum Lizenzserver getrennt wird. Im Folgenden sind einige Beispiele für typische Fehlerbedingungen und -meldungen aufgeführt:

Getrennte Lizenzverbindungen
Möglicherweise werden Meldungen wie die Folgende zurückgegeben:

Lizenzverbindung getrennt Verbindung mit dem Lizenzserver für ArcGIS for Desktop Advanced (ARC/INFO) getrennt. Es wird alle 120 Sekunden versucht, die Verbindung wiederherzustellen: Versuch 1 von 5...

ArcGIS Desktop-Fehler
Wenn eine VPN-Verbindung instabil ist, werden ggf. Indikatoren innerhalb der Benutzeroberfläche eingeblendet, die auf eine fehlerhafte Verbindung zu den Quelldaten hinweisen, wie z. B. rote Ausrufezeichen neben den Geodatabase-Verbindungsdateien in ArcGIS Pro.

Abbildung mit roten Ausrufezeichen neben den Geodatabase-Verbindungsdateien in ArcGIS Pro

Oder es befinden sich rote Ausrufezeichen neben defekten Layer-Datenquellen in Kartendokumenten, wie unten gezeigt.

Abbildung defekter Layer-Datenquellen in Kartendokumenten mit roten Ausrufezeichen daneben

Außerdem werden beim Speichern von Änderungen, Erstellen neuer Features, Zeichnen oder Hinzufügen neuer Layer in ArcMap folgende Arten von Fehlern zurückgegeben:

Änderungen speichern Änderungen können nicht gespeichert werden. Zugrunde liegender DBMS-Fehler [ORA-03114: not connected to ORACLE] [SDE.DEFAULT]
Neue Features konnten nicht erstellt werden. Zugrunde liegender DBMS-Fehler [sde.DEFAULT]
Darstellung eines oder mehrerer Layer ist fehlgeschlagen. Städte in den USA: Zugriff auf den DBMS-Server fehlgeschlagen [ORA-03114: not connected to ORACLE::...]
Öffnen ist fehlgeschlagen Fehler beim Öffnen einer Feature-Class FDO-Fehler: -2147155559 Zugriff auf den DBMS-Server fehlgeschlagen[[Microsoft][ODBC Treiber 17 für SQL Server]Communication link failure] [world01.sde.GBD_Items]

Allgemeine Datenbankverbindungsfehler
Bei dem Versuch, eine Verbindung mit einer Datenbank über VPN herzustellen, können eine ganze Reihe von Fehlern zurückgegeben werden. Diese Meldungen können unterschiedlich detailliert sein. Im Folgenden finden Sie einige Beispiele:

Verbindung Es kann keine Verbindung zum Datenbankserver hergestellt werden, um die Datenbankliste abzurufen. Überprüfen Sie den Servernamen, Benutzernamen und das Kennwort, und versuchen Sie es erneut. Zugrunde liegender DBMS-Fehler...
Error: Zugrunde liegender DBMS-Fehler
Verbindungsfehler Verbindung zur angegebenen DBMS-Instanz fehlgeschlagen. Es ist ein Datenbankverbindungsfehler aufgetreten. FDO-Fehler: -2147155559.

Ursache

GIS-Anwendungen haben einen hohen Bedarf an Netzwerkbandbreite, und GIS-Daten werden über ein zentrales Daten-Repository gemeinsam verwendet und gespeichert. Die meisten dieser Performance-Probleme sind auf unzureichende Bandbreiten über VPN-Verbindungen zurückzuführen, wie beispielsweise beim Arbeiten in ArcMap oder ArcGIS Pro über Verbindungen mit einer Enterprise-Geodatabase. Der Zugriff auf eine Enterprise-Geodatabase, ob unter Microsoft SQL Server, Oracle oder einem anderen RDBMS, über eine Internetverbindung wird immer langsam sein. Es gibt jedoch einige Workarounds, die unten beschrieben werden.

Einige Operationen und Workflows beanspruchen Netzwerkverbindungen mehr als andere, je nachdem, welche Anwendungen verwendet werden. Beispielsweise ist ArcMap "kommunikativer" als ArcGIS Pro. Wenn Sie zudem einen neuen Computer für den Remote-Zugriff verwenden, ist dieser möglicherweise noch nicht für die Arbeit mit ArcGIS optimiert.

Wenn im Lizenzmanager eine unzureichende Reaktionszeit festgelegt wurde, können Lizenzserver-Timeouts auftreten. Diese Einstellung kann zurückgesetzt werden, und eine alternative Verwendung der Lizenzierung kann ebenfalls Lizenzserver-Timeouts entgegenwirken.

Lösung oder Problemumgehung

Allgemeine Empfehlungen

Hinweis: Es wird dringend empfohlen, bei der Fehlerbehebung in Ihrer Umgebung zum Zweck der Ursachenermittlung, sämtliche geprüften Einstellungen und die Ergebnisse aller durchgeführten Tests, z. B. der Bandbreite, Datenbankverbindungen, Netzwerklatenz usw. zu notieren. Diese Informationen können für die technische Analyse durch den Support, an den Sie sich wenden – Ihr ISP, die eigene IT-Abteilung oder die Esri Support Services – sehr hilfreich sein.

Beginnen Sie mit möglichen lokalen Problemen in Zusammenhang mit Verbindungen zur ArcGIS Plattform. Überprüfen Sie die von Ihrem ISP bereitgestellte Bandbreite. Wenn Sie über eine ausreichende Bandbreite verfügen, untersuchen Sie zunächst die VPN-Verbindung. Es empfiehlt sich hierbei im Allgemeinen:

  • Vermeiden Sie, dass zwei Computer im selben WLAN eine VPN-Verbindung verwenden.
  • Stellen Sie die Verbindung zum Router über ein LAN-Kabel her.
  • Starten Sie den Router neu.
  • Stellen Sie sicher, dass im Betriebssystem/Benutzerprofil geeignete Berechtigungen für die auf dem PC installierte VPN-Software erteilt wurden.
  • Achten Sie darauf, dass die Kommunikation nicht über Firewalls oder Virenschutz-Anwendungen eingeschränkt wird.
  • Führen Sie einen Geschwindigkeitstest für das Netzwerk aus. Diese Informationen können hilfreich sein, um die maximal verfügbare Bandbreite zu ermitteln. Die App "Network Speed Test" steht auch über den Microsoft Store zur Verfügung.
  • Verwenden Sie RDP anstelle von VPN.

Einige Benutzer haben möglicherweise einen neuen Laptop für die Remote-Arbeit erhalten, und wenn ein VPN oder eine Datenbank nicht bekannt ist, sind für den Computer möglicherweise einige Konfigurationseinstellungen erforderlich, um die Verwendung von ArcGIS zu optimieren. Empfehlungen für die Performance-Optimierung finden Sie unter den unten im Abschnitt "Zugehörige Informationen" angegebenen Links.

Wenn sämtliche dieser grundlegenden Probleme ausgeschlossen werden können, sollten Sie sich eventuell an Ihre interne IT-Abteilung wenden. Es gibt bestimmte Netzwerkempfehlungen, die bei der Optimierung der ArcGIS Plattform hilfreich sein können, und möglicherweise muss das Design der Systemarchitektur erneut überprüft werden, um sicherzustellen, dass Spitzenbelastungen des Netzwerks, wie unter System Design Process: Network Communications beschrieben, den Anforderungen an die Benutzer-Performance gerecht werden.

Getrennte Lizenzverbindungen
Mögliche Lösungen für diesen Fehler sind unter anderem die Verlängerung der Lizenz, das Ausleihen von Lizenzen anstelle einer ständigen Belastung des Lizenzservers und das Hosten von ArcGIS Pro-Lizenzen in ArcGIS Online. Siehe hierzu:

ArcGIS Desktop-Fehler

  • Die Darstellungs-Performance in ArcMap kann durch die Verwendung eines Feature-Cache auf Desktop-Seite verbessert werden. Siehe: Arbeiten mit dem Feature-Cache
  • Migrieren Sie, sofern möglich, Workflows in ArcGIS Pro, da das Netzwerk hierdurch weniger belastet wird, als mit ArcMap und Lizenzen in ArcGIS Online gehostet werden können.
  • Erstellen Sie ein lokales Replikat der Enterprise-Geodatabase, und synchronisieren Sie das Replikat später, wenn alle Änderungen durchgeführt wurden.
  • Löschen Sie den Anzeige-Cache. Der Anzeige-Cache ermöglicht das Schwenken und Zoomen in der vorhandenen Karte. Wird der Cache allerdings von einer Karte bis zur nächsten beibehalten, führt dies zu großen Performance-Einbußen. Klicken Sie in ArcMap auf Anpassen > ArcMap-Optionen. Klicken Sie auf der Registerkarte Anzeige-Cache auf Cache löschen.
  • Löschen Sie den Geoverarbeitungsverlauf, indem Sie zu Geoverarbeitung > Geoverarbeitungsoptionen navigieren und unter Ergebnisverwaltung die Einstellung in Niemals speichern oder Ergebnisse sollten nicht älter sein als 1 Tag ändern.

Allgemeine Datenbankverbindungsfehler

  • Achten Sie darauf, dass die RDBMS-Client-Software ausgeführt wird und so konfiguriert ist, dass Remote-Verbindungen zugelassen werden.
  • Stellen Sie sicher, dass Sie bezüglich Datenbankverwaltung und Patches auf dem neuesten Stand sind.
  • Führen Sie Datenbankverwaltung über Nacht mithilfe geplanter Tasks durch.

Die folgenden Tests können dabei behilflich sein, die Ursache der Probleme einzugrenzen, und helfen Ihrem Ansprechpartner beim technischen Support, Fehler zu beheben:
Führen Sie über die Eingabeaufforderung folgende Befehle aus:

  • Führen Sie Ping für den Datenbankserver aus, und notieren Sie sich die Antwortzeiten und eventuelle Paketverluste.
  • Führen Sie tracert aus. Wie viele Hops gab es? Gibt es Anforderungs-Timeouts?
Hinweis: Verwenden Sie beim Ausführen von Befehlen die IP-Adresse des Servers anstelle des HOSTNAME.
  • Wenn Sie eine Datenbankverbindung herstellen, führen Sie telnet für den Server mit der Portnummer aus, den die Datenbank überwacht. Ist der Port geöffnet?
  • Überprüfen Sie die Firewall-Einstellungen und/oder Gruppenrichtlinien. Sie sollten diese jedoch nicht deaktivieren, auch nicht zu Testzwecken.

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