Deutsch
Continue in the app
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

How To: Export an attribute table from ArcGIS Pro to Microsoft Excel

Zusammenfassung

Das Exportieren einer Attributtabelle aus ArcGIS Pro in Microsoft Excel ist ein häufig verwendeter Workflow, da einige Datensätze in ArcGIS Pro nicht editierbar sind oder wenn die Attributtabelle ohne Änderung der ursprünglichen Datensätze extern geändert werden muss. In diesem Artikel werden einige Methoden beschrieben, mit denen eine Attributtabelle zur externen Bearbeitung aus ArcGIS Pro in Microsoft Excel exportiert werden kann.

Vorgehensweise

Verwenden Sie eine der folgenden Methoden, um eine Attributtabelle aus ArcGIS Pro in Microsoft Excel zu exportieren:

Exportieren Sie die Attributtabelle mithilfe des Werkzeugs "Tabelle in Excel".

  1. Öffnen Sie ein ArcGIS Pro-Projekt. Klicken Sie im oberen Menüband auf Analyse > Werkzeuge.
  2. Suchen Sie im Bereich Geoverarbeitung nach Tabelle in Excel (Conversion Tools), und klicken Sie auf die Option. Das Fenster Tabelle in Excel wird geöffnet. Klicken Sie im Fenster Tabelle in Excel auf Parameter.
  3. Klicken Sie auf das Dropdown-Menü für Eingabetabelle oder auf Durchsuchen (das Ordnersymbol), und wählen Sie den Feature-Layer mit der gewünschten Attributtabelle aus.
  4. Klicken Sie im Abschnitt Ausgabe-Excel-Datei (.xls oder .xlsx) auf Durchsuchen (das Ordnersymbol).
Abbildung des Fensters
  1. Geben Sie im Fenster Ausgabe-Excel-Datei (.xls oder .xlsx) einen Speicherort für die Microsoft Excel-Datei an. Geben Sie im Fenster Name einen Namen für die Microsoft Excel-Datei an.
  2. Klicken Sie auf das Dropdown-Menü Alle unterstützten, wählen Sie ein Format (.xls oder .xlsx) für die Microsoft Excel-Datei aus, und klicken Sie auf Speichern.
Abbildung des Fensters
  1. Klicken Sie im Werkzeug Tabelle in Excel auf Ausführen.
  2. Navigieren Sie in Windows zum angegebenen Speicherort. Die Attributtabelle wird exportiert und kann als Microsoft Excel-Arbeitsblatt geöffnet werden.

Exportieren der Attributtabelle in eine CSV-Datei

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den gewünschten Feature-Layer, und wählen Sie Daten > Tabelle exportieren aus.
  2. Klicken Sie im Fenster Zeilen kopieren auf das Dropdown-Menü für Eingabezeilen oder auf Durchsuchen (das Ordnersymbol), und wählen Sie einen gewünschten Feature-Layer aus.
  3. Klicken Sie unter Ausgabetabelle auf Durchsuchen (das Ordnersymbol).
Abbildung des Werkzeugs
  1. Geben Sie im Fenster Ausgabetabelle einen Ordnerpfad für die exportierte Tabelle an. Geben Sie im Abschnitt Name einen Namen mit der Dateierweiterung .csv für die exportierte Tabelle an, und klicken Sie auf Speichern.
Abbildung des Fensters
  1. Klicken Sie im Fenster Zeilen kopieren auf Ausführen.
  2. Navigieren Sie in Windows zum angegebenen Speicherort. Die Attributtabelle wird exportiert und kann als Microsoft Excel-Datei mit kommagetrennten Werten geöffnet werden.

Kopieren aller Datensätze der Attributtabelle und Einfügen der Datensätze in eine Microsoft Excel-Datei

  1. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den gewünschten Feature-Layer, und klicken Sie auf Auswahl > Alles auswählen, um alle Datensätze in der Attributtabelle auszuwählen.
  2. Klicken Sie im Bereich Inhalt mit der rechten Maustaste auf den gewünschten Feature-Layer, und wählen Sie Attributtabelle aus, um diese zu öffnen.
  3. Klicken Sie im Abschnitt Feld der Attributtabelle auf Kopieren, um alle Datensätze zu kopieren.
Abbildung von
  1. Öffnen Sie eine neue Microsoft Excel-Datei.
  2. Klicken Sie in der Microsoft Excel-Datei auf die Zelle A1. Wählen Sie unter Option "Einfügen" eine gewünschte Einfügeoption aus, und fügen Sie die Datensätze ein.
  3. Speichern Sie die Datei.

Referenzinformationen

Zuletzt geändert: 3/20/2022

Artikel-ID: 000021825

Software: ArcGIS Pro 2.4.3, 2.4.2, 2.4.1, 2.4, 2.3.3, 2.3.2, 2.3.1, 2.3, 2.2.4, 2.2.3, 2.2.2, 2.2.1, 2.2, 2.1.3, 2.1.2, 2.1.1, 2.1, 2.0.1, 2.0