PROBLEM

Medien werden in der ArcGIS Survey123-Web-App und der mobilen ArcGIS Survey123-App nicht angezeigt

Last Published: May 12, 2022

Beschreibung

Es kann nützlich sein, in einem Survey-Formular Medien wie Audio und Bilder zur besseren Visualisierung einzufügen. Es kann jedoch vorkommen, dass die Medien im Survey-Formular in der Survey123-Web-App und der mobilen Survey123-App nicht angezeigt werden, nachdem sie über ArcGIS Survey123 Connect veröffentlicht wurden.

Die folgende Abbildung zeigt ein unvollständiges Survey-Formular, das in der Survey123-Web-App geöffnet wurde. Die Bilder werden nicht angezeigt, und anstelle des Audio-Inhalts wird die Fehlermeldung "Ungültige Quelle" zurückgegeben.

Unvollständiges Survey-Formular ohne Bilder und Audio

Ursache

In den Feldern für die Medien liegt eine fehlerhafte Groß- und Kleinschreibung der Dateinamen vor. In Survey123 muss die Groß-/Kleinschreibung berücksichtigt werden. In der XLSForm-Tabelle müssen die Dateinamen und Dateierweiterungen in den Medienfeldern mit derselben Groß- und Kleinschreibung erfasst werden, die in den Eigenschaften der Mediendateien angegeben ist.

Beispielsweise hat "Bird" in der folgenden Tabelle die Dateierweiterung ".jpg" (Kleinbuchstaben) anstelle von ".JPG", und die Dateierweiterung von "Wildlife" lautet ".Mp3" (M ist ein Großbuchstabe) anstelle von ".mp3". Dahingegen wird der Buchstabe "J" von "jellyfish" klein statt groß geschrieben ("Jellyfish").

Fehlerhafte Groß-/Kleinschreibung der Medienerweiterungen in den Medienfeldern

Lösung oder Problemumgehung

Fügen Sie, um das Problem zu beheben, die korrekten Dateinamen und Dateierweiterungen in die Medienfelder ein.

  1. Klicken Sie im Medienordner mit der rechten Maustaste auf die Audio- oder Bilddatei, und wählen Sie Eigenschaften aus.
  2. Notieren Sie sich die Schreibweise der Dateierweiterung (Groß- oder Kleinschreibung), die auf der Registerkarte Allgemein unter Dateityp angezeigt wird. Klicken Sie auf OK.
Das Fenster
  1. Öffnen Sie in ArcGIS Survey123 Connect die XLSForm-Tabelle.
  2. Fügen Sie in den Spalten media::audio und media::image die korrekten Dateinamen und Dateierweiterungen entsprechend der Groß-/Kleinschreibung der Mediendateien ein.
Das XLS-Formular zum Eingeben der Dateierweiterungen in korrekter Schreibweise
  1. Veröffentlichen Sie den Survey erneut, und öffnen Sie das Survey-Formular in der Survey123-Web-App und der mobilen Survey123-App.

Die folgende Abbildung zeigt das Survey-Formular, nachdem die Dateinamen und Dateierweiterungen korrekt umbenannt wurden. Die Bilder "Bird" und "Jellyfish" sowie das Audio "Wildlife" werden korrekt in der ArcGIS Survey123-Web-App wiedergegeben.

Das Fenster der ArcGIS Survey123-Web-App, in dem die Bilder

Artikel-ID:000021388

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden