ERROR

3079: Die Domäne ist bereits vorhanden in Collector for ArcGIS

Last Published: February 9, 2023

Fehlermeldung

Beim Laden einer Karte in Collector wird im Werkzeug "Layer" die folgende Fehlermeldung zurückgegeben, und der Layer mit dem Fehler wird nicht geladen:

"Error 3079: Die Domäne ist bereits vorhanden" 

Ursache

Dieser Fehler tritt auf, wenn alle folgenden Bedingungen für den Layer gelten:

  • Es handelt sich um einen gehosteten Feature-Layer, der in ArcGIS Online (zum Beispiel aus einer Vorlage oder aus einem vorhandenen Feature-Layer) vor dem Update 7.1 (März 2019) erstellt wurde.
  • Er enthält mehrere Layer.
  • Mindestens zwei der Layer enthalten Felder mit identischem Namen, aber unterschiedlichen Listen (Domänen), und die Listen wurden in ArcGIS Online erstellt.

Ein Beispiel wäre ein gehosteter Feature-Layer mit Informationen zu Parkanlagen, der einen Layer für Pfade (Linien) und einen Layer für Flächen (Polygone) enthält. In diesem Beispiel-Layer enthalten der Pfade- und der Flächen-Layer jeweils das Feld "surface_type" mit einer Liste (Domäne). Bei Pfaden kann der Oberflächentyp befestigt, Schmutz, oder Schotter festgelegt sein, bei Flächen dagegen der Oberflächentyp befestigt, Gras, Schmutz, Schotter oder Sand. Obwohl der Name der Felder identisch ist, unterscheiden sich die Auswahlmöglichkeiten in der Liste (Domäne).

Bei Daten mit dieser Struktur, die in ArcGIS Online vor dem Update 7.1 (März 2019) erstellt wurden, wird in Collector dieser Fehler gemeldet, da die Listen (Domänen) denselben Namen erhalten haben.

Lösung oder Problemumgehung

Bearbeiten Sie die Domänen, und speichern Sie sie dann erneut, um die Namen der Listen (Domänen) entsprechend der Domänenbenennungskonvention, die in ArcGIS Online im Update 7.1 (März 2019) eingeführt wurde, zu aktualisieren. Wenn die aktualisierten Namen eindeutig sind, verschwindet der Fehler, und der Layer wird geladen. Siehe Bearbeiten einer Liste von Werten.

Hinweis:
Diese Fehlermeldung können Sie auch dann erhalten, wenn mit ArcMap oder ArcGIS Pro mehrere Layer aus unterschiedlichen Geodatabases und mit Domänen identischen Namens in einen einzelnen gehosteten Feature-Layer veröffentlicht wurden. Da diese Domänen nicht in ArcGIS Online erstellt wurden, lässt sich dieses Problem mit der obigen Lösung nicht beheben. Um diese Layer zu korrigieren, verwenden Sie einen der folgenden Workarounds:

• Aktualisieren Sie die Domänennamen in den Geodatabases so, dass sie eindeutig sind, und veröffentlichen Sie den Layer erneut, oder

• Veröffentlichen Sie jeden Layer als separaten gehosteten Feature-Layer in ArcGIS Online (statt einen einzelnen gehosteten Feature-Layer mit beiden Layern darin zu veröffentlichen).

Artikel-ID:000020922

Hilfe von ArcGIS-Expert*innen erhalten

Technischen Support kontaktieren

Die Esri Support-App herunterladen

Zu den Download-Optionen

Weitere Informationen zu diesem Thema erkunden